What are the System Requirements for the PostGopher Plugin?

You'll need a standard host, a self-hosted WordPress site 4.4 (or higher) with a minimum of PHP 5.3 (5.6+ Recommended). This is standard on 99% of hosting platforms and a minimum standard for many commercial plugins.